Back to overview
Degraded

Subscription Billing Configuration Issue

Apr 14, 2026 at 10:20am UTC
Affected services
Orchestration API

Resolved
Apr 14, 2026 at 12:16pm UTC

The fix has been deployed to production. All recurring subscriptions will now bill at their correct pricing going forward. No historical charges were modified. Affected merchants should review subscription billing between March 20 and April 14 for any discrepancies.

Updated
Apr 14, 2026 at 11:30am UTC

A fix has been implemented and is undergoing testing before deployment. We plan it to be in production within an hour.

Updated
Apr 14, 2026 at 10:55am UTC

The issue has been traced to a release on March 20, meaning existing recurring subscriptions may have been billed at trial pricing since that date. A fix is being developed.

Created
Apr 14, 2026 at 10:20am UTC

We received a report that some existing recurring subscriptions were being billed at trial pricing instead of their regular pricing. We're investigating the issue