Refund Processing Issue for Adyen Payments
Resolved
Feb 25, 2026 at 1:30pm UTC
The issue has been resolved. Refunds for Adyen payments are now processing correctly. Merchants who initiated refunds during the affected period should verify their refund status and resubmit any that did not go through.
Affected services
Updated
Feb 25, 2026 at 9:00am UTC
The issue has been identified. Refunds are failing for payments configured with automatic capture in Odus where delayed capture is enabled in Adyen. A fix is being developed.
Affected services
Created
Feb 25, 2026 at 8:30am UTC
We received reports that some refunds initiated through Odus for Adyen payments were not being processed. We're investiagting
Affected services