Back to overview
Degraded
Degradation of Payment API performance
May 16, 2026 at 3:19pm UTC
Affected services
Orchestration API
Checkout
Resolved
May 16, 2026 at 4:51pm UTC
Issue is now resolved
Affected services
Created
May 16, 2026 at 3:19pm UTC
We are experiencing an increased load and the API latency is higher than usual
Affected services