Back to overview
Degraded

Degradation of Payment API performance

May 18, 2026 at 6:29am UTC
Affected services
Orchestration API
Checkout

Resolved
May 18, 2026 at 7:11am UTC

The fix was applied, all services are recovered

Updated
May 18, 2026 at 6:46am UTC

We have identified the issue and are applying the fix

Created
May 18, 2026 at 6:29am UTC

Payment requests latency is higher than average