Back to overview
Resolved

Payment services and Dashboard are down

Aug 6, 2026 at 2:17pm UTC
Affected services
Payments
Dashboard

Resolved
Aug 6, 2026 at 2:25pm UTC

The incident was resolved, all systems operational

Updated
Aug 6, 2026 at 2:20pm UTC

We have identified the issue, fix is being applied

Created
Aug 6, 2026 at 2:17pm UTC

We are working on identifying the issue